PHP 7.2+ Required for WooCommerce 6.5

PHP 7.2+ Required for WooCommerce 6.5

PHP 7.2+ Required for WooCommerce 6.5

It’s been a while since WooCommerce’s minimum PHP version updated to 7.0, and it’s about time for another update. WooCommerce will require PHP 7.2 or newer to run starting with version 6.5, which is set to be released in May 2022.

Why this change?

The PHP ecosystem is rapidly changing. PHP 8.0 and 8.1 are the only versions of PHP that are actively maintained at the time of writing; PHP 7.4 is in “security fixes only” mode, while PHP 7.3 is no longer supported as of December 2021. For performance and security reasons, WordPress recommends at least PHP 7.4, and these considerations are much more relevant for an e-commerce site.

WooCommerce is also reliant on a number of third-party programs, many of which are phasing out support for earlier PHP versions. This is already generating problems, since finding packages that support the entire range of PHP versions from 7.0 to 8.1 is becoming increasingly difficult.

According to the statistics, 7.2 is the oldest version with a large number of active WooCommerce installations. It’s worth noting that just roughly half of the sites using PHP 7.0 or 7.1 appear to be being maintained, meaning they’re using a WooCommerce version that’s no more than six months old.

What happens if you don’t upgrade?

Your WooCommerce instance will continue to operate if your server is still running PHP 7.0 or 7.1 when WooCommerce 6.5 is released, but you won’t be able to upgrade past WooCommerce 6.4. (or any 6.4.x maintenance release published afterwards).

To maintain your WooCommerce sites up to date, performance, and safe, we strongly recommend updating your servers to PHP 7.4.


Best WooCommerce 6.0.x WordPress Themes

BROWSE ALL THEMES


Featured Theme Collections:

Best selling multi vendor wordpress themes

 Best Selling Multi Vendor MarketPlace WordPress Themes

You might also like

Leave Your Comment

x
Quà Tết Cao Cấp Hộp quà tết Giỏ quà tết Túi quà tết